Jump to content
Excelsior Forums

spectdev

Members
  • Content count

    0
  • Joined

  • Last visited

Everything posted by spectdev

  1. JET 8 mp1 JetPackII issue

    We are having an intermittent issue with JetPackII ever since migrating to JET 8 mp1 from JET 7.6. The issue was present in JET 8 (without mp1) and is still present after applying mp1. This is on a Windows 8 build machine. Our previous build machine was running Windows 7. When using the Excelsior Jet Installer option for packaging, the resulting executable is most often corrupted. We get the error as per the attached image. This happens irregardless of the compression method used. This is also happening on all of our software projects. If we try multiple times, we eventually get a good executable. However, this trial and error approach is getting time consuming. Right now, we have to run JetPackII, test and repeat until we get an executable that finally works. Please help.
  2. JET 8 mp1 JetPackII issue

    Anyone?
  3. Guys, I am trying to automate the packaging of my application, but I have run into a roadblock. My build process generated a folder with hundreds of files, which I include in my JetPackII project. The issue here is that the files in that folder change at every build. As such, I am not able to use xpack as it complains that the previously included files are not longer there. How can I get xpack to understand that the folder was updated with new files such that it updates the project info and builds successfully? Thanks.
  4. Thanks for the reply. I am glad this is being looked into for future releases. I will look into your suggestion for the time being.
  5. JET version 7.2. I had reported a similar issue in the past: As mentioned in that thread, the issue was related to not properly detaching the native thread from the JVM. This current report, however, is different. I am making sure to properly detach my native threads from the JVM, but I am getting error with different severity on Windows than on Linux. On Windows, I get occasional "SuspendThread failed with error 5 (handle xxx, ID xxxx)", but the application does not crash. On Linux, however, I get "SuspendThread failed with error 3 (handle xxxxxxx, ID xxxxxxxxxx)" and it crashes the application. Questions: Is JET the one calling SuspendThread? I ask that as no where in my code SuspendThread is being called. Can JET provide some type of notification before a thread is suspended and after it is resumed? Here is an excerpt from an strace on Linux:
  6. SuspendThread failed with error

    As a follow up to this issue, the problem was indeed in my app and was related to improperly detach the native threads from the VM. Thanks.
  7. SuspendThread failed with error

    Here is a more recent failure: error 1 AJ-runtime trap: kind = 1, source = D:\JetCheck\buildsystem-distribs\distribs\jet_pro_en\build\aj-runtime\rt-normal\core\runtime\windows\java\com\excelsior\jet\runtime\os\OSThread.java, line = 166 error 2 Unexpected OS failure: SuspendThread() failed (error code 5) error 3 JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR #44 (runtime trap). Please, contact the vendor of the application. Extra information about error is saved in the "jet_err_11444.txt" file.
  8. SuspendThread failed with error

    Okay, I have upgraded to JET 7.6 but still getting the same error only with more preceding failures this time.. The errors in the Windows event viewer are in this order: 1. AJ-runtime trap: kind = 1, source = D:\JetCheck\buildsystem-distribs\distribs\jet_pro_en\build\aj-runtime\rt-normal\core\runtime\windows\java\com\excelsior\jet\runtime\os\OSThread.java, line = 166 2. Unexpected OS failure: SuspendThread() failed (error code 5) 3. JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR #44 (runtime trap). Please, contact the vendor of the application. Extra information about error is saved in the "jet_err_2212.txt" file.
  9. Is there any update on this?
  10. Hi, I would like to request that, for applications being packaged as services, both the option to run as Local System or a given user account be presented to the users. Right now, one has to package the application with either option active. That is, if we offer the user to pick a user account, then cannot choose to run the application as Local System and vice-versa. It would be nice to have both options. Thanks.
  11. There are a few JVM options that I would like to be able to pass dynamically to my applications. The standard has been to specify such options through JAVA_TOOL_OPTIONS. However, JAVA_TOOL_OPTIONS is not being picked up in JET compiled applications. Thanks.
  12. To be a little more specific, I am trying to get my application to support different locales.
  13. Hi, I have an application that works fine when not compile by Excelsior JET. However, after being compiled by JET, I get the following error when exiting from a thread that returned from a JNI call:
  14. SuspendThread failed with error 5

    Thanks e.v.e! I did find on my own that the issue was indeed related to not calling DetachCurrentThread.
  15. SuspendThread failed with error 5

    Windows XP SP2 virtual box and Windows XP SP3 physical box. Thanks.
  16. SuspendThread failed with error 5

    Forgot to add, this is using Excelsior JET 6.4 Pro. Thanks.
  17. Custom Uninstall

    I am also interested in this topic. Instead of us writing custom DLLs, why not provide a generic DLL that calls a shell script or two or just the ability to run a few shell scripts before the uninstall proceeds? Thanks.
  18. Crypto is broken in 6.40

    1. The same project built using 6.0 works but fails if built with 6.4 with a java.security.NoSuchAlgorithmException error. 2. Further, if I try to rebuild the project after making some changes, I get:
  19. Problem with Log4j

    Hi, I have a problem with log4j. My application was compiled with Jet 6.0. The application works fine as a standalone Java application. It seems like the application, once compiled with Jet 6, is not able to pick up the log4j.properties file. The message I get is: Setting the log4j.configuration system property to point to the log4j file does not help. Doing "SET JETVMPROP=-Djet.stack.trace" is of no help either. Please see into this issue. Thanks.
  20. Problem with Log4j

    FYI, I fixed my problem by doing this in my LogFactory class: static { PropertyConfigurator.configure(System.getProperty(JavaSysEnvVariablesConstants.USER_DIR) + "/log4j.properties"); }
×