Jump to content
Excelsior Forums

doanchu

Members
  • Content count

    0
  • Joined

  • Last visited

Everything posted by doanchu

  1. When running a Java program which uses JXBrowser as an embedded browser on a Mac Laptop running MacOSX Sierra 10.12.3, I faced this following problem: The application has started with command line: java -cp /Users/god/Github/spam_jxbrowser/out/artifacts/spam_jxbrowser_jar/spam_jxbrowser.jar:/Users/god/Github/spam_jxbrowser/out/artifacts/spam_jxbrowser_jar/darcula.jar:/Users/god/Github/spam_jxbrowser/out/artifacts/spam_jxbrowser_jar/jxbrowser-6.12.jar:/Users/god/Github/spam_jxbrowser/out/artifacts/spam_jxbrowser_jar/runtime.jar:/Users/god/Github/spam_jxbrowser/out/artifacts/spam_jxbrowser_jar/jxbrowser-mac-6.12.jar Main --------------------------------------------------------------------------- JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR: system exception at 0x000000010a71eaaf Please, contact Excelsior Support at <java@excelsior-usa.com>. Extra information about error is saved in the "jet_err_8590.txt" file. 2017-02-06 21:21:33.703 xjava[8590:855000] CFUserNotificationDisplayAlert: called from main application thread, will block waiting for a response. --------------------------------------------------------------------------- The application has terminated with exit code: 137 The error log is (partial): JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR: system exception at 0x000000010a71eaaf Please, contact Excelsior Support at <java@excelsior-usa.com>. Signal 11 (SIGSEGV) siginfo: si_signo 11, si_errno 0, si_code 1, si_addr 0x0000000000000004 PID 8590, TID 0x00007fff942593c0 Registers: RAX = 0x0000000000000000 RBX = 0x000000010b5576f8 RCX = 0x00007fff57a8c13c RDX = 0x000000010c7c4158 RSI = 0x00007fff57a8c0e8 RDI = 0x000000010b561b78 RBP = 0x00007fff57a8c178 RSP = 0x00007fff57a8bfb0 R8 = 0x00000000ff8a58a5 R9 = 0x0000000000000000 R10 = 0x0000000000000004 R11 = 0x0000000000000000 R12 = 0x000000010b4eaef0 R13 = 0x00000000ff8a58a5 R14 = 0x00007fff57a8c278 R15 = 0x00007fe36592c000 RIP = 0x000000010a71eaaf (/Users/god/opt/jet11.3-eval-amd64/profile1.8.0_101/develop/bin/libPKRN11308101.dylib+0x2544aaf) The application runs fine on Windows.
  2. Hi, The problem is reproducible with Yosemite. What do I need to provide in order to have this bug fixed?
  3. Problem with JXBrowser

    Running this sample program import com.teamdev.jxbrowser.chromium.Browser; import com.teamdev.jxbrowser.chromium.BrowserType; import com.teamdev.jxbrowser.chromium.Callback; import com.teamdev.jxbrowser.chromium.swing.BrowserView; import com.teamdev.jxbrowser.chromium.swing.internal.LightWeightWidget; import javax.imageio.ImageIO; import java.awt.*; import java.awt.image.RenderedImage; import java.io.File; /** * The sample demonstrates how to get screen shot of the web page * and save it as PNG image file. */ public class HTMLToImageSample { public static void main(String[] args) throws Exception { // #1 Create Browser instance Browser browser = new Browser(BrowserType.LIGHTWEIGHT); BrowserView view = new BrowserView(browser); // #2 Set the required view size browser.setSize(1280, 1024); // Wait until Chromium resizes view Thread.sleep(500); // #3 Load web page and wait until web page is loaded completely Browser.invokeAndWaitFinishLoadingMainFrame(browser, new Callback<Browser>() { @Override public void invoke(Browser browser) { browser.loadURL("https://teamdev.com"); } }); // Wait until Chromium renders web page content Thread.sleep(500); // #4 Get java.awt.Image of the loaded web page. LightWeightWidget lightWeightWidget = (LightWeightWidget) view.getComponent(0); Image image = lightWeightWidget.getImage(); ImageIO.write((RenderedImage) image, "PNG", new File("teamdev.com.png")); // Dispose Browser instance browser.dispose(); } } resulted in this error: The application has started with command line: java -cp /Users/doanchu/Github/testjxbrowser/out/artifacts/testjxbrowser_jar/jxbrowser-6.2.jar:/Users/doanchu/Github/testjxbrowser/out/artifacts/testjxbrowser_jar/jxbrowser-mac-6.2.jar:/Users/doanchu/Github/testjxbrowser/out/artifacts/testjxbrowser_jar/testjxbrowser.jar:/Users/doanchu/Github/testjxbrowser/out/artifacts/testjxbrowser_jar/license.jar HTMLToImageSample --------------------------------------------------------------------------- dyld: lazy symbol binding failed: Symbol not found: _JVM_ArrayCopy Referenced from: /Users/doanchu/Downloads/jet11.0-eval-amd64/profile1.8.0_72/jre/lib/libosx.dylib Expected in: /Users/doanchu/Downloads/jet11.0-eval-amd64/profile1.8.0_72/jre/lib/jetvm/libjvm.dylib dyld: Symbol not found: _JVM_ArrayCopy Referenced from: /Users/doanchu/Downloads/jet11.0-eval-amd64/profile1.8.0_72/jre/lib/libosx.dylib Expected in: /Users/doanchu/Downloads/jet11.0-eval-amd64/profile1.8.0_72/jre/lib/jetvm/libjvm.dylib --------------------------------------------------------------------------- The application has terminated with exit code: 133 Could you tell me what is wrong with Excelsior JET configuration? Update: this only happens with Excelsior Jet 11 for Mac.
  4. Problem with JXBrowser

    Hi, I am using OS X El Capitan. I think it is JET's bug too. This is the link for jar files for JXBrowser: http://cloud.teamdev.com/downloads/jxbrowser/jxbrowser-6.2-cross-desktop-win_mac_linux.zip This is the evaluation license: https://www.teamdev.com/e/dc3d976e-1fd1-40f1-a4ab-603cc63e4a92/ The previous example runs perfectly fine on Windows.
×