Jump to content
Excelsior Forums
Sign in to follow this  
stroy

Error (54) message question

Recommended Posts

I have been writing programs in XDS Modula-2 for years with great success, but now I am having trouble with a program, using the Win32 interface, that puts a lot of data onto the heap.  The program runs fine with smaller amounts of data but behaves erratically with large amounts of data.  I tried increasing the memory allocations in the project file, with no improvement.   I tried converting the main module from Modula-2 to Oberon-2 (my first use of Oberon) in order to gain garbage collection.  This compiles with no errors, but gives the following error on linking: "Error (54): Name 'main' not found (referenced in file xstart.asm (library C:\XDS\lib\x86\xstart.lib}}"  None of my program uses assembly language, so I don't understand this message, and I can't find any mention of this error message in any of the XDS documentation.  Can anybody suggest why I might be getting this message, or what to do about it?  

Share this post


Link to post
Share on other sites

Hi,

  You get this error if you haven't specified the MAIN compiler option in the module containing the entry point for your code.

Just insert <* MAIN+ *> above the MODULE statement.

e.g.

<* MAIN+ *>

MODULE MainModule;

Alan.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×