Jump to content
Excelsior Forums
gemma

DEBIAN 5.0 and XDS-x86

Recommended Posts

Hi John,

Few months ago, you sent me a solution for my wrong PATH into rc.red file...Now, I would like to ask help from you because and I have to install Debian 5.0 with gcc-4.2.3 and I am not able to buil the library...same returns me this error I attach you (I have just installed ncurses-dev indeed)

Thank you for all your time and help! :)

gemma.txt

Share this post


Link to post
Share on other sites

I had the same problem in Ubuntu 8.04.  (This seems to have been reported as Bug #442418 to the Debian list, with the claim that it is now fixed.)  According to what I found, the problem is claimed to be due to compiling in 32-bit mode on a 64-bit machine.

Following instructions I found on the web, I removed the inclusion of /usr/include/asm/sigcontext.h on line 193 of X2C.c (by enclosing it in comments) and it now seems to work (so far).

Perhaps Snowman may wish to comment further on this.

john

Share this post


Link to post
Share on other sites

Thank you very much! :)

I got to compile finally, updating all libraries and ncurses-dev from the Debian repository and all it's fine and work with Modula2.

Thanks, again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×