Jump to content
Excelsior Forums

Recommended Posts

Hello all,

Been using the free version for a while, before the latest update. Didn't notice the problem immediately, but the first time (after Excelsior's update) I built an .eiu-based update to my previous setup and ran it, I was a bit surprised not to get the installation folder automatically in the "Destination folder" dialog box. I hit the browse folder and navigated to it, but then I got the following message: "Can not install son-and-so to the specified directory because it does not contain so-and-so" (that's obviously not my app name, just avoiding noise).

Thinking something might've been altered/deleted/somehow-messed-with in the original installation, I wiped it out from the disk, set it up again with the original setup program and tried again the update - same result.

Suspecting the problem could then be on the updater, I built a "new original setup" with the latest Excelsior release using my app's old sources (trying to recreate the same situation as much as possible), wiped out my app again, reinstalled it with the "new original setup", ran the update and - voila! - it worked as expected.

Thinking then that the .eiu was somehow corrupted, I recreated it using the "new original setup", built a new update based on it and tried the new update on another computer which also had the app installed with the true original setup - no joy!

At this point I can only think there is an issue with the new Excelsior Delivery release. Has anyone experienced anything similar? Found a workaround?

Thanks!

Share this post


Link to post
Share on other sites

Thank you very much for your report! We feel so sorry for the inconvenience caused.

We cannot reproduce the issue on our side unfortunately. Would you please kindly tell us more details about your primary and update packages.

Please, check your email for detailed instructions. The letter's title is 'Re: Excelsior Installer "Update won't... update"'.

Thank you in advance,

Konstantin

Excelsior Support Team

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×