Jump to content
Excelsior Forums
Sign in to follow this  
ravigupta

Running binary build on 32 bit machine on 64 bit server

Recommended Posts

I have compiled a java application on my laptop (32bit) to executable code using Excelsior JET. I deployed the same on 64 bit machine and ran it. But on giving command ./myapp, it says "Not a valid Directory/File name". Should i compile my java app on 64 bit machine to run on same platform. Also why is not detecting any file that is present in the folder. It just says "Not a valid Directory/Filename".

Thanks in advance.

Ravi

Share this post


Link to post
Share on other sites

Hello Ravi,

Should i compile my java app on 64 bit machine to run on same platform?

Excelsior JET currently cannot produce 64-bit binaries so there is no difference on which system you compile your application, it should work on 64-bit systems in 32-bit mode.

Could you provide following information:

  • what OSes are installed on the laptop and the 64-bit machine?
  • does the application work correctly on the laptop?
  • how do you deploy your application on the 64-bit machine? Are you using JetPackII?

Best regards,

Vladimir Parfinenko

Excelsior Support

Share this post


Link to post
Share on other sites

Hello Vladimir,

what OSes are installed on the laptop and the 64-bit machine?

OS on my laptop: Linux ishan-laptop 2.6.31-23-generic #75-Ubuntu SMP Fri Mar 18 18:08:39 UTC 2011 i686 GNU/Linux

OS on 64bit machine: Linux ubuntu001 2.6.32-29-server #58-Ubuntu SMP Fri Feb 11 21:06:51 UTC 2011 x86_64 GNU/Linux

does the application work correctly on the laptop?

Yes, It works perfectly on my laptop. I ran the binary created using JetPackII. And that ran on my laptop.

how do you deploy your application on the 64-bit machine? Are you using JetPackII?

I created a package using JetPackII. I used option "Self-contained directory" in packaging option.

I ran ./myapp on my laptop. It worked perfectly. I copied the same package folder on 64 bit machine. and ran with same command.

This is the commmand and output:

sysadmin@ubuntu001:~/shineindexing$ ./myapp

-bash: ./myapp: No such file or directory

Thanks

Ravi

Share this post


Link to post
Share on other sites

I copied the same package folder on 64 bit machine. and ran with same command.

This is the commmand and output:

sysadmin@ubuntu001:~/shineindexing$ ./myapp

-bash: ./myapp: No such file or directory

You need to install the 32-bit libraries:

sudo apt-get install ia32-libs

and optionally ask Ubuntu/Debian devs to replace that error message with something a bit more helpful. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×