Jump to content
Excelsior Forums
excbv

a bug involving ProgExec.Execute in XDS v. 2.60 beta 2

Recommended Posts

Hello,

I have installed XDS Native v. 2.60 beta 2 under Windows 7. When recompiled

with v. 2.60 most of my Oberon2 stuff works OK; however, I have encountered

a problem with XDS, v. 2.60 beta 2, that was not present in v. 2.51.

I have a large program that uses ProgExec.Execute (and it works perfectly when

built with XDS Nativ v. 2.51), and it apparently crashed on calling this function.

Unfortunately, I wasn't able to get more details because the smaller examples

that I tried worked OK. I also tried to use the debugger on the larger program,

but the crash came rather abruptly with the program only showing some assembly

code. The crash itself produced the following data:

#RTS: unhandled exception #3: invalid location

File errinfo.$$$ created.

EAX = 00000000 EBX = 00000000

ECX = 00000000 EDX = 0000001C

ESI = 0006F7E4 EDI = 0006F858

EBP = 0006F7D0 ESP = 0006F7CC

EIP = 002875D7

STACK:

0006F7CC: 00000000 0006F7DC 0028E36E 00000000

0006F7DC: 0006F888 0028E32F 7A20432F 652E7069

0006F7EC: 20206578 6E203E32 20206C75 5C3A4D22

0006F7FC: 68637241 5C657669 6B636142 5C737075

0006F80C: 706D6574 6E706B62 2220226D 2D202022

0006F81C: 203C2040 5C3A4322 72657355 6F425C73

0006F82C: 616A7473 6F4C5C6E 206C6163 74746553

0006F83C: 73676E69 6D65545C 6D745C70 34393170

C:\Users\Bostjan\Documents>type errinfo.$$$

C:\Users\Bostjan\AppData\Local\Bin\Brst.exe @

#RTS: unhandled exception #3: invalid location

000065D7 00000000 C:\Users\Bostjan\AppData\Local\Bin\XDS26.DLL

0000D369 00000000 C:\Users\Bostjan\AppData\Local\Bin\XDS26.DLL

0000D32A 00000000 C:\Users\Bostjan\AppData\Local\Bin\XDS26.DLL

00004B3F 00000000 C:\Users\Bostjan\AppData\Local\Bin\STD.DLL

00006A83 00000000 C:\Users\Bostjan\AppData\Local\Bin\STD.DLL

0000716A 00000000 C:\Users\Bostjan\AppData\Local\Bin\Brst.exe

000046E4 00000000 C:\Users\Bostjan\AppData\Local\Bin\Brst.exe

0000CD5E 00000000 C:\Users\Bostjan\AppData\Local\Bin\Brst.exe

0000A9B0 00000000 C:\Users\Bostjan\AppData\Local\Bin\Brst.exe

0000E8B9 00000000 C:\Users\Bostjan\AppData\Local\Bin\Brst.exe

0000EEDA 00000000 C:\Users\Bostjan\AppData\Local\Bin\Brst.exe

0000B54A 00000000 C:\Users\Bostjan\AppData\Local\Bin\STD.DLL

00001DCD 00000000 C:\Users\Bostjan\AppData\Local\Bin\STD.DLL

Regarding more information, as I have already mentioned the procedure

ProgExec.Execute works OK on smaller examples; therefore, the problem is

pretty tricky from my standpoint. However, if you can give me instructions

on how to gather more information, I could do that.

Regards,

excbv

Share this post


Link to post
Share on other sites

Another remark concerning ProgExec.Execute: I thought that replacing ProgExec.Execute with ProgExec.ExecuteNoWindow (which had been added to the corresponding .def file in v. 2.60 beta 2) at a certain place in my program would prevent the crash that I mentioned in my previous post. However, after this change I discovered that the linker in XDS v. 2.60 beta 2 cannot find ProgExec.ExecuteNoWindow. I then searched the lib/x86/xds26i.lib file and, in fact, could not find that name. Again, is this a bug, or am I not understanding something?

Regards,

excbv

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×