Jump to content
Excelsior Forums
keith

SOLVED: NoClassDefFound

Recommended Posts

My application is crashing and taking all the diagnostics with it. So I decided to do a test run in the Control Panel. When I did, I got the following error.

java.lang.NoClassDefFoundError: com.ardor3d.util.resource.URLResourceSource

at com.ardor3d.renderer.state.TextureState.<clinit>(Unknown Source)

at com.excelsior.jet.runtime.classload.ClassInitialization.__aj__initClass__Lcom_excelsior_jet_runtime_typedesc_ClassOrInterfTypeDesc_2(Unknown Source)

at com.ardor3d.renderer.state.RenderState.createState(Unknown Source)

at com.ardor3d.renderer.RenderContext.setupRecords(Unknown Source)

at com.ardor3d.renderer.RenderContext.<init>(Unknown Source)

at com.ardor3d.framework.lwjgl.LwjglCanvasRenderer.init(Unknown Source)

at com.ardor3d.framework.lwjgl.LwjglCanvas.init(Unknown Source)

at com.ardor3d.framework.FrameHandler.init(Unknown Source)

at com.performanceplanningsystem.ThreeD.ardor3d.PPSBase.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

com.ardor3d.util.resource.URLResourceSource is in my source code compiled into a jar.

app.jar is where all my source code is compiled

jar tvf app.jar returns

3128 Wed Jan 16 15:18:54 CST 2013 com/ardor3d/util/resource/SimpleResourceLocator.class

5464 Wed Jan 16 15:18:54 CST 2013 com/ardor3d/util/resource/URLResourceSource.class

So, any suggestions about why I'm getting a NoClassDefFound or how to get better diagnostics?

Share this post


Link to post
Share on other sites

After making some changes to the code, none of which had to do with ardor3d, a recompile solved the problem. So (rhetorical question) what happened?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×