Jump to content
Excelsior Forums
scov

Modifying JIT Compiler settings in JET 9.0 in migrated project

Recommended Posts

Hello,

I ran into a certain issue while migrating our project to a newer Excelsior version. Not sure if this is an issue per-se, or we are just using some deprecated features. Or something else I'm missing altogether.

We've been using the Professional version of Excelsior for a while. Initially, we used Excelsior 6.4, then I migrated our project to 8.0 and now trying to do the same to 9.0 (latest maintenance pack installed).

While the transition from 6.4 to 8 has been smooth (no changes made to either the prj file or jpn), I encounter a rather interesting issue when attempting to migrate the project to the latest Excelsior.

As soon as I install the kit (created through INNO Setup) and start the application, I am greeted by a message that reads: "Warning: unknown JET property: jet.jit.cache." Once acknowledged, the application continues to run normally. (As it stands, in the docs, under "JET Runtime-specific properties", I see no mention of this property; nor was I able to find a list with all the available ones. As a side-note, in the JetPackII we also use the -D jet.jit.fast, which is also not mentioned there at least...yet I don't get any runtime warning for this property.)

To give a complete description of the situation:

1. In both versions of JetPack II (8.0 and 9.0, same underlying jpn file loaded) I have the same flags: -D jet.jit.fast and -D jet.jit.cache.

2. Same prj file loaded in the Excelsior control panel:

- in Excelsior 8.0, step 4, under JIT Compiler: JIT operation mode = Fast (lower overhead); JIT caching mode = Enabled (use default directory);

- Excelsior 9.0, same context: JIT operation mode = Fast (lower overhead) - even if I select another option under from the drop-down box, it will revert to this selection; JIT caching mode - again, no matter what I select, it defaults back to Disabled. I guess this is why I get the warning at runtime.

The only other difference between the two setups I can think of is that Excelsior 9 runs on a Windows XP over a virtual machine, while the other's host is a physical machine, XP as well.

Thank you.

Share this post


Link to post
Share on other sites

Hello,

To give a complete description of the situation:

1. In both versions of JetPack II (8.0 and 9.0, same underlying jpn file loaded) I have the same flags: -D jet.jit.fast and -D jet.jit.cache.

2. Same prj file loaded in the Excelsior control panel:

- in Excelsior 8.0, step 4, under JIT Compiler: JIT operation mode = Fast (lower overhead); JIT caching mode = Enabled (use default directory);

- Excelsior 9.0, same context: JIT operation mode = Fast (lower overhead) - even if I select another option under from the drop-down box, it will revert to this selection; JIT caching mode - again, no matter what I select, it defaults back to Disabled. I guess this is why I get the warning at runtime.

Thank you.

Caching JIT was deprecated in Excelsior JET 8.0 and it's now removed (since version 9.0). For more details, refer to the Deprecated Features chapter of Excelsior JET 8.0 User's Guide.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×