Jump to content
Excelsior Forums
jt2030

Invalid Excelsior JRE directory path canonicalization failed

Recommended Posts

I have compiled my java application and packed it with the JetPackII, I put the files on my memory stick and tried it on another computer and it worked fine but then I gave the exe and the 'rt' folder to a friend to try

and he was getting this error:

"Invalid Excelsior JRE directory path canonicalization failed"

I assumed it was because he didn't have JRE installed but then I saw that the JetPackII packs what looks like JRE into it so is this not the problem? if not what else could cause this error?

Share this post


Link to post
Share on other sites

First of all, make sure to copy the EXE file that was processed by the packager (JetPackII), not the EXE originally emitted by the compiler. If you build a new EXE, you have to re-package it before copying to other PCs; there is a command-line tool for that called xpack.

Also, if you do not have the latest update installed (for Excelsior JET 9 it is Maintenance Pack 2 as of today), install it then rebuild and re-package your app.

If nothing helps: What are your friend's operating system and its language settings?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×