Jump to content
Excelsior Forums
Sign in to follow this  
RJ1

Issue with useSystemProxies

Recommended Posts

It seems that in v9.0 the useSystemProxies is true by default

I have tried setting it to false, but it still uses socks proxy to connect to a socket, and it's failing.

The code I have is:

Socket socket = new Socket();

socket.connect(new InetSocketAddress(host, port), 5000);

and this connect is using the system proxy. This works ok with jre7 u71, but does not work with JET v9 (I am using update 2).

I have fixed one program by making the following change. But there is another program, which is using nio, and I can't change it.

Socket socket = new Socket(Proxy.NO_PROXY);

socket.connect(new InetSocketAddress(host, port), 5000);

Please let me know if you need more information. Thanks.

Share this post


Link to post
Share on other sites

It seems that in v9.0 the useSystemProxies is true by default

I have tried setting it to false, but it still uses socks proxy to connect to a socket, and it's failing.

The code I have is:

Socket socket = new Socket();

socket.connect(new InetSocketAddress(host, port), 5000);

and this connect is using the system proxy. This works ok with jre7 u71, but does not work with JET v9 (I am using update 2).

I have fixed one program by making the following change. But there is another program, which is using nio, and I can't change it.

Socket socket = new Socket(Proxy.NO_PROXY);

socket.connect(new InetSocketAddress(host, port), 5000);

Please let me know if you need more information. Thanks.

Hello,

Unfortunately we didn't managed to reproduce the problem on our side.

Even if invalid system proxy is set, JET-compiled application successfully establishes socket connection.

Could you please provide us some additional information about your problem?

Please send us (java@excelsior-usa.com) small example program where the problem is reproduced and corresponding JET project file (.prj).

Excelsior Support Team.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×