Jump to content
Excelsior Forums
scov

Starting compiled Tomcat fails with error

Recommended Posts

Hello,

I have been trying to compile & run a web application (under Tomcat7) using ExclesiorJet11 but I am stuck.

I managed to successfully compile the app with 0 errors but when I try to run it I get the following error message:

JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR: runtime error

This Tomcat application runs in a protected environment

which has detected that app configuration has changed unexpectedly.

This error may occur if you replace/change/delete some webapps.

Try to recompile the application. If the error persists please, contact Excelsior Support Dept. at java@excelsior-usa.com

Please, contact Excelsior Support at <java@excelsior-usa.com>.

Extra information about error is saved in the "jet_err_952.txt" file.

I am unsure why this is happening, so could anyone please give me some leads.

Here is some extra info about the system I am running on:

Version Information:

Java version: 1.8.0_40

Excelsior JET 11.00 Enterprise edition

JET Profile: Java SE version: 1.8.0_40; JET update level: 0; CPU architecture: amd64

Runtime: Server

CPU features: cmov mmx sse sse2 sse3 ssse3 sse4.1 cx8 cx16

OS:

CentOS Linux 7 (Core)

Linux 3.10.0-327.4.5.el7.x86_64 #1 SMP Mon Jan 25 22:07:14 UTC 2016 x86_64

glibc 2.17

Thanks

Share this post


Link to post
Share on other sites

I am receiving the same error with the app I am using during my 30-day trial, before I commit to buying.

Have you emailed java@excelsior-usa.com yet?  I will do so shortly.

Share this post


Link to post
Share on other sites

Usually this kind of error appears if you change some configuration files of your Tomcat application after it has been compiled using Excelsior JET. Please make sure that it is not the case.

 

Please note that the most recent versions of Tomcat are not supported by Excelsior JET 11.0. Try to use Tomcat 7.0.59 or earlier for your application and check if error persists.

Alternatively, you can try out our Excelsior JET 11.3 beta for amd64 platforms at http://www.excelsiorjet.com/beta, which has full Tomcat 7 and 8 support. 

Please contact us at java@excelsior-usa.com if none of these helps.

 

--

Excelsior Support

Share this post


Link to post
Share on other sites
On 10/6/2016 at 7:29 PM, Ken said:

I am receiving the same error with the app I am using during my 30-day trial, before I commit to buying.

Have you emailed java@excelsior-usa.com yet?  I will do so shortly.

Thank you Vladimir!  I had not changed any configuration files, however I was running Tomcat 7.0.70 when I experienced the problem.  I downgraded to 7.0.59 as you suggested and was successful!

 

----------------------------------------------------

Hello Ken,

 

Usually this kind of error appears if you change some configuration files of your Tomcat application after it has been compiled using Excelsior JET. Please make sure that it is not the case.

 

Please note that the most recent versions of Tomcat are not supported by Excelsior JET 11.0.

What is your version of Tomcat? Try to use Tomcat 7.0.59 or earlier for your application and check if error persists.

Alternatively, you can try out our Excelsior JET 11.3 beta for amd64 platforms at http://www.excelsiorjet.com/beta, which has full Tomcat 7 and 8 support.

 

Regards,

Vladimir Parfinenko

Excelsior Support

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×