Jump to content
Excelsior Forums

Can't load Excelsior JET on Linux

Recommended Posts


Somehow when I run Excelsior JET on one of my Xubuntu machine, it gives me this error:

Exception in thread "main" java.lang.NoClassDefFoundError: java.awt.Frame
    at com.excelsior.wizard.win.Splash.register(Unknown Source)
    at com.excelsior.wizard.Txt.<clinit>(Unknown Source)
    at com.excelsior.wizard.Txt.<unknown>(Unknown Source)
    at com.excelsior.wizard.win.Main.damagedJRE_unknown(Unknown Source)
    at com.excelsior.wizard.win.Main.<unknown>(Unknown Source)
    at com.excelsior.wizard.win.Main.main(Unknown Source)

and if I run JetPackII

I'm getting different error:

Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load library: /home/wikes/apps/jet11/profile1.8.0_91/jre/lib/i386/libawt_xawt.so
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.load0(Unknown Source)
    at java.lang.System.load(Unknown Source)
    at java.lang.ClassLoader$NativeLibrary.<unknown>(Unknown Source)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.<unknown>(Unknown Source)
    at java.awt.Toolkit$3.run(Unknown Source)
    at java.awt.Toolkit$3.<unknown>(Unknown Source)
    at java.security.AccessController.<unknown>(Unknown Source)
    at java.awt.Toolkit.loadLibraries(Unknown Source)
    at java.awt.Toolkit.<clinit>(Unknown Source)
    at java.awt.Toolkit.loadLibraries(Unknown Source)
    at java.awt.Component.<clinit>(Unknown Source)
    at com.excelsior.dwizard.win.Splash.register(Unknown Source)
    at com.excelsior.dwizard.win.Main.<clinit>(Unknown Source)
    at java.lang.Class.<unknown>(Unknown Source)
    at java.lang.Class.forName(Unknown Source)
Could not find the main class: com/excelsior/dwizard/win/Main

Share this post

Link to post
Share on other sites

I figured out what was wrong, after investigating using ldd, it can't find libXtst.so.6 

turns out I had 64bit version installed on my linux install, all I did just ran this command to install the i386 version and it works now

sudo apt-get install libxtst6:i386

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now