Jump to content
Excelsior Forums
Vash

org.modelmapper.PropertyMap issues

Recommended Posts

I'm compiling a tomcat application. Everything works fine, except one thing. 

In the application I have the following:

import org.modelmapper.PropertyMap;

public class MyPropertyMap extends PropertyMap<X, Y> {
    @Override
    protected void configure() {
       map().getSomeProperty().setAnotherProperty(source.getId());
    }
}

When I run the native compiled exe, the above runs fine.

When I run the same exe through the trial run in JetPack II, I get a nullpointer exception in the map()... line. I assume because geSomeProperty() somehow returns null, or source is null, or both.

What could be the issue? 

Share this post


Link to post
Share on other sites

It looks like a configuration issue if you code works fine after compilation and throws NPE while trial run in JetPackII. Maybe your application requires some configuration/property files or it depends on current directory.

Does the problem reproduce after packaging ignoring results of trial run?

Is it possible to add debug print in configure() method (i.e. print value of map(), map().getSomeProperty(), source)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×