Jump to content
Excelsior Forums

Unable to get Redirection to work.

Recommended Posts

Hi,  I am desperately in need of some help, I  am trying to convert a few simple programs written with Topspeed M2 back in the 90's.

However I cannot seem to get the redirection file to work,  I am using  PC- Linux-OS.

usr/local.xds/bin   is in the $PATH        and      XDS is installed in /usr/local.

I have created a sub directory of the xds directory   /p0,   and xcwork from p0 has created the  def, obj, src, sym  directories.

I have put 2 files in xds/p0/def     they are  mylib.def  and  mylib.mod

PART of REDIRECTION FILE   in the xds directory. =

*.def  = ./def;/p0/def      also tried       *.def  = ./usr/local/xds/p0/def
However I always get a  "no such file"  Error

[dave@localhost xds]$ xc mylib.def
file open error: "mylib.def" no such file

I even tried putting  the mylib.def file in  usr/local/xds/def/xds      with other def files.

and every other combination that I can think of,  always the   SAME Error

Any help / suggestions  most welcome


Share this post

Link to post
Share on other sites

Many thanks for the Reply.

XDS re-installed, just the same. i've made some progress with the file Name and the Path.

Seems  that the Dos file name "MENUS..DEF" is unacceptable, but "Menus.def" is Ok.

Although the xc.red file in the xds directory has   *.def  = ./def;./p0/def

I have to use xc ./p0/def/FileName  on the command line, not sure why ?

So now I can get the compiler to work, but immediately hit an error problem, as this is unrelated

to this post I have started a new post for the error problem.


Dave P..









Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now