Jump to content
Excelsior Forums
Sign in to follow this  
DavePritchard

DSO missing from command line,

Recommended Posts

Hi,   I am stuck again,  I have compiled a small programme "Latin.mod"   xc =m Latin.mod   ( converted from Topspeed )

Although the files compile without errors,  it still fails.

The following indicates the problem, or problems, but it is meaning less to me.

[ CODE ]

files: 6  errors: 0(21)  lines 8737  time: 0:00  speed 1747400 l/m
gcc  -o Latin obj/Kb1.o obj/Latin.o obj/Latin0.o obj/Menus.o obj/Mylib.o  /usr/local/xds/lib/x86/libts.a /usr/local/xds/lib/x86/libxds.a  -lm -lncurses
/usr/bin/ld: /usr/local/xds/lib/x86/libts.a(xtsConM.o): undefined reference to symbol 'curs_set'
/lib64/libtinfo.so.5: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
tmp.mkf:33: recipe for target 'Latin' failed
make: *** [Latin] Error 1
external command fault 2:
make -f tmp.mkf
[dave@localhost xds]$

[ END CODE ]

If someone could explain what I need to do to resolve this, and get a working programme, I will be very happy, any assistance welcome.

Best Regards  Dave P..

 

Share this post


Link to post
Share on other sites

Hi Hady,  many thanks for the reply.

ncurses is not on the system,  I have just tried everything on another system which has ncurses installed, but the ncurses files are different, there are no -dev files,

Also I forgot that I need to include /usr/local/xds  in the PATH.   So I failed to get it working.  I copied all  the ncurses files found in lib64 on the other system, back to the first system, but the same error occured.  Downloading files is a problem as I am using PC-Linux with KDE-4 which is no longer supported, the other system has KDE-5 Plasma, which is all bugs, but does have  ncurses installed    .   RPM's are  listed  listed for many other distros but not for PC_Linux,  So I need a little more time to sort my way through this.

 

*******   CONTINUED  on  the 19-April-18  The Latest failures  *********

(*   With system still using KDE4  *)

[root@localhost Downloads]# rpm -i libtinfo-5.9-alt10.x86_64.rpm
error: Failed dependencies:
        terminfo = 5.9-alt10 is needed by libtinfo-5.9-alt10.x86_64
        rpmlib(SetVersions) is needed by libtinfo-5.9-alt10.x86_64

[root@localhost Downloads]# rpm -i terminfo-5.9-59.1.x86_64.rpm
warning: terminfo-5.9-59.1.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 3dbdc284: NOKEY
        file /usr/share/terminfo/r/rxvt-cygwin from install of terminfo-5.9-59.1.x86_64
conflicts with file from package ncurses-5.9-9pclos201

[ USING FIND : ncurses-5.9-9pclos201  NOT FOUND, terminfo-5.9-59.1.x86_64 NOT FOUND ]

(*   From the above it would appear that ncurses is installed somewhere, but I cannot fine it *)

Your search rpmlib(SetVersions) did not match any entry in database.

[root@localhost Downloads]# rpm -i libncurses-devel-5.9-alt10.x86_64.rpm
error: Failed dependencies:
        libncurses = 5.9-alt10 is needed by libncurses-devel-5.9-alt10.x86_64
        libtinfo-devel = 5.9-alt10 is needed by libncurses-devel-5.9-alt10.x86_64

[root@localhost Downloads]# rpm -i libncurses-5.9-alt11.i586.rpm
error: Failed dependencies:
        libtinfo = 5.9-alt11 is needed by libncurses-5.9-alt11.i586
        libgpm.so.1 >= set:jgGopviN0XPf is needed by libncurses-5.9-alt11.i586

(*    

So into dependency hell,  and the conclusion , I seem to be getting nowhere, so I will try with the system running KDE5 ( as buggy as it is

At least it has the following ncurses installed :

lib64ncurses5
llib64ncurses
lb64ncurses-devl
lib64ncursesw5
lib64ncursesw6
lib64ncursesw-devl

(* But a different error has shown up as follows. *)

* [./p0/src/Latin.mod 27.12 F425]
* file open error: "FIO.sym" no such file
IMPORT  FIO$;
errors  1, no warnings, lines   27, time  0.01
[dave@localhost xds]$

(*

This and similar errors looks to me like the Topspeed  bits are not being accessed, but as everything was copied over from the other system I am stumped  as to why.  and I still don't know if the original error will be cleared or not.   .

*)

Dave P..

Edited by DavePritchard
Additional Info..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×