Jump to content
Excelsior Forums
SourceSkyBoxer

Common problem if I use large jar with lwjgl 3.1x and swt 4.6.x with 64 Bit - Test run can't work

Recommended Posts

Hello everyone, 

I am using Excelsior Jet 15.0 ( amd64 )

I have tried - It is nothing happen with large jar if I used before 32bit ( x86 ) than I tried with amd64 ( x64 ) than it shows dump file ( large over than 300 mb )

I will upload to you via mega.nz - If your country can't see mega.nz than you can use evading vpn connector 

1. Test Run output:

The application has started with command line:
java -cp C:\Users\SSB\Documents\MyDevJava\TestWithATSWING\SwtDemo\MyApp.jar;C:\Users\SSB\Documents\MyDevJava\TestWithATSWING\SwtDemo SwtDemo 
---------------------------------------------------------------------------
[LWJGL] Failed to retrieve the JVMTI interface pointer.
JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR: system exception at 0x00007ffdde143bb9
Please, contact Excelsior Support at <java@excelsior-usa.com>.
Crash dump will be written to "C:\Users\SSB\Documents\MyDevJava\TestWithATSWING\SwtDemo\jet_dump_12180.dmp"
Extra information about error is saved in the "jet_err_12180.txt" file.


---------------------------------------------------------------------------
The application has terminated with exit code: 9

jet_err_12180.txt ( mega.nz )

jet_dump_12180.dmp ( mega.nz )

 

How do I fix that. I have tried - no success with x64 bit :/ But I don't believe that I have already tested with x86 = it works fine - I really don't understand why does it happen? It is really impossible to happen with Excelsior Jet 15 stopped work for large jar with embedded dlls if they copy to temp directory. 

 

Thanks and sorry my bad English!

// EDIT: Found lwjgl 3.1 can't do with lwjgl 3.1 That is why we need report to lwjgl 3.1 creators

But I have tested with Lwjgl 2.9.3 + Swt 4.7.2 = It works fine no problem and no crash.

For Lwjgl 3.1.6 / 3.1.7 doesn't work :(

Share this post


Link to post
Share on other sites

Yes please check forum of lwjgl

Quote

Excelsior JET does not support JVMTI. LWJGL requires JVMTI for the OpenGL and OpenGL ES bindings only, it is used to avoid a thread-local lookup per function call.

This issue is not acceptable, I'll post again when I figure out a solution.

You need JVMTI to excelsior jet thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×