Jump to content
Excelsior Forums
Sign in to follow this  
charles

On runtime: ?"internal error: SHA-1 not available"

Recommended Posts

Hi all,

Here's my situation:

I've created and compiled (with Jet 3.15 using j2sdk1.4.2 / JRE 1.4.2) a server application which runs just fine as an .exe (both with and without use of the JetPackII installer for setup) on my development system but which crashes immediately with the following error printed in the console window:

"Exception in thread "main" java.lang.InternalError: internal error: SHA-1 not available."

...whenever I attempt to run the application after deploying it to another system (with a fresh install of Windows XP) via the JetPackII self-extracting installer.

The console window indicating the error is up for a split second before exiting.  (the application does not normally operate with a console window, I've only included it with the build to troubleshoot this issue)

A bit of searching in the newsgroups indicates that this error may be related to the cryptographic classes in Java.  I am using Blowfish for encryption (with Cipher.getInstance("Blowfish"); ) but this is the first time I've come across this error.

Has anyone else come across this particular error and have suggestions as to how I might resolve it?

Thanks,

 -Charles

Share this post


Link to post
Share on other sites

Hi Folks,

I managed to solve this problem and thought I'd post a follow-up for anyone experiencing something similar.

As being able to run the compiled .exe on the development computer should have told me:  I was missing some runtime components in the JetPackII package I was deploying.  Once I included the missing runtime components, the .exe worked flawlessly.

For my own application, I found specifying the following runtime components:

    - JIT

    - XKRN

    - XMIS

    - XRMI

    - XSQL

    - XSND

    - XJCE

    - XSEC

    - XSSE

    - XAWT

    - XCRB

    - XMIA

    - XJIT

    - XLINK

In Step 5 of the JetPackII package creation mechanism solved my problem.  Your own particular mix may vary and selecting the option to include all runtime components in the JetPackII package may help to identify if missing components are the cause of your particular problem.

Share this post


Link to post
Share on other sites

Hi,

I have the same problem.

I want to compile my exe file directly with the command prompt and jc.

How can I write it in a .prj file?

How should I declare these options?

Thanks,

Veronique.

Share this post


Link to post
Share on other sites

For the original problem (charles) the advice is simple - never ignore Trial Run in JetPackII. The trial run includes all JET RT components required by the application automatically.

The 2nd problem (bh) is not related to the original one. The syntax of the project files is described in JET User's Guide. But, I cannot understand why not use GUI tools?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×