Jump to content
Excelsior Forums
Sign in to follow this  
harry

JET RT (root dir)

Recommended Posts

hi... I made jet compiled exe (for jetty). but when i am making setup.exe using Jet Pack-II, i incuded jet compiled exe. At that time its creating "JET RT" that contains dll files (size: 27.7 MB).  I am not able to remove "JET RT" directory while making setup.exe.

Can any one help me out in this regard?

Thank you in advance....

Share this post


Link to post
Share on other sites

JET RT is absolutely required for running your JET-compiled application. So there is no way to remove it.

If you need  EXE that does not require JET RT, try to use JetPerfect.

Share this post


Link to post
Share on other sites

Thank you for your reply. ?I am trying to make EXE with JetPerfect.

I got ".use" file by the command

SET JETVMPROP=-Djet.usage.list -Djet.default.classloader:bootstrap abc.exe

recompiling with the command "jc =p abc +perfect" to make a single "EXE" and getting the message like ".usg file should be specified in perfect mode".

I am not sure how to pass the ".use" file for the above said compilation command to recompile the application to get "EXE" which will not use JET RT.

I would appreciate if some one can help me in this...

Share this post


Link to post
Share on other sites

Hi... I read the document and able to create ".usg" file. But I am not able to do the following things:

1. not able to execute the command "!module abc.usg". How can i execute this command?

2. When i recompile the project "abc.prj" with the command "jc =p abc +perfect", I am getting the error ".usg file should be specified in perfect mode". How can set I this?

appreciated your help.

Share this post


Link to post
Share on other sites

"!module abc.usg" is not a command, it should be a line in abc.prj.

From Jet UG -- "Append a line specifying the automatically generated .usg file to your project file. For example, if the target executable name is MyApp.exe, add the following line to the project file:

:huh:?!module?MyApp.usg

".

So you need add line "!module abc.usg" to abc.prj. And read carefully Jet UG the next time, :).

Share this post


Link to post
Share on other sites

thank you for your info. I added the following lines to abc.prj and able recompile the application.

-IncludeTimeZoneInfo+

-IncludeDetectedLocales+

-IncludeLoggingAPI-

!module abc.usg

When I am tring to run the abc.exe, getting the exception "java.lang.NullPointerException".

looking forward for your help...

Share this post


Link to post
Share on other sites

java.lang.NullPointerException may be caused by many reasons from incomplete testing of your not jetperfected EXE to absence of resources you forgot to bind with EXE.

So you'd better to get formal JET support available via http://www.excelsior-usa.com/jetsupportform1.html where you should describe your problem carefully, at least specify stack trace of those exception.

Share this post


Link to post
Share on other sites

I am able to make jet compiled EXE in perfect mode. when i try to run this EXE, i am getting the following warning and error messages:

Warning! Unknown JET property: jet.jit

Warning! Unknown JET property: jet.jit.cache

java.lang.reflect.InvocationTargetException

Caused by: java.lang.NoClassDefFoundError:

defineClass failed: JIT is disabled

java.net.SocketException: accept() (code=10004)

java.net.SocketException: net dll not initialized (WSAStartup): accept()

java.net.SocketException: net dll not initialized (WSAStartup): accept()

How can i enable JIT? I have the following options in project file:

-classabsence=IGNORE

-compilerheap=0

-heaplimit=0

-inlinelimit=100

-inlinetolimit=1000

-jetvmprop=-Djet.jit -Djet.jit.cache -Djet.gc.heaplimit:0

-stacklimit=900000

-standaloneresources=

I would appreciate if any can help me in this.

Share this post


Link to post
Share on other sites

JetPerfect and JIT are mutually exclusive. The whole idea of JetPerfect is that it precompiles all classes of your application and therefore can make more optimizations.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×