Jump to content
Excelsior Forums
Sign in to follow this  
eXOR

Together 6.0 building with JET

Recommended Posts

First of all :-). Jet compiler is cool :). Swing GUI works much faster... but but but... :)

I've tried to build Together 6.0 with JET compiler jet3.6-eval under linux

$ uname -a

Linux 2.6.9 #16 Wed Oct 20 17:32:27 NOVST 2004 i686 athlon i386 GNU/Linux

Together worked fine for me with jdk1.3.1_11 this was the jdk I gave to JET when it requested.

I've built it with the following project file:

= START =====================================

-compilerheap=300M

-inline

+gendebug

+lineno

-TGH:=.

+ignoreclassduplication

-CLASSABSENCE=HANDLE

+ignorememberabsence

-main=com/togethersoft/together/Main

-jetvmprop=-Xms64m -Xmx512m

-lookup=*.class=$(JDK_HOME)/lib/tools.jar

-lookup=*.class=$(TGH)/lib/i18n;$(TGH)/lib/coroutine;$(TGH)/lib/Java2COM

!package *.class com

%!module $(TGH)/lib/jndi.jar

!module $(TGH)/lib/together.jar

!module $(TGH)/lib/tgscilib.jar

!module $(TGH)/lib/openapi.jar

!module $(TGH)/lib/gifs.zip

!module $(TGH)/lib/jgl.zip

!module $(TGH)/lib/jacl.jar

!module $(TGH)/lib/uddi4j.jar

!module $(TGH)/lib/mail.jar

!module $(TGH)/lib/xalan.jar

!module $(TGH)/lib/xerces.jar

!module $(TGH)/lib/tcljava.jar

!module $(TGH)/lib/jcvs/jars/jcvsii.jar

!module $(TGH)/lib/jcpagelayout.jar

!module $(TGH)/lib/misclib.zip

!module $(TGH)/lib/javax.jar

!module $(TGH)/lib/jhall.jar

!module $(TGH)/help/together-help.jar

!module $(TGH)/bundled/tomcat/lib/servlet.jar

!module $(TGH)/lib/soap.jar

!module $(TGH)/bundled/j2ee/lib/j2ee.jar

!module $(TGH)/lib/guiBuilderBeanInfo.jar

= END =================================

it took about 6 hours to build the whole project

$ cat /proc/cpuinfo | grep "model name"

model name      : AMD Athlon XP 2600+

$ cat /proc/meminfo | grep MemTotal

MemTotal:       515596 kB

....

after project was built I used the following file to run Together:

= START ======================

# SKIPED COMMON HEADER

export JETVMPROP=$hpfix -noverify -Djvm.dir=$JVM_DIR -Xms64m -Xmx512m

export CLASSPATH=$TGH/lib/together.jar:\

$TGH/lib/tgscilib.jar:\

$TGH/lib/openapi.jar:\

$TGH/modules:\

$TGH/lib/gifs.zip:\

$TGH/out/classes:\

$TGH/lib/i18n:\

$TGH/lib/jgl.zip:\

$TGH/lib/jacl.jar:\

$TGH/lib/uddi4j.jar:\

$TGH/lib/mail.jar:\

$TGH/lib/xalan.jar:\

$TGH/lib/xerces.jar:\

$JNDI\

$TGH/lib/tcljava.jar:\

$TGH/lib/jcvs/jars/jcvsii.jar:\

$TGH/lib/jcpagelayout.jar:\

$TGH/lib/misclib.zip:\

$TGH/lib/javax.jar:\

$JDK_TOOLS_JAR:\

$TGH/lib/jhall.jar:\

$TGH/help/together-help.jar:\

$TGH/bundled/tomcat/lib/servlet.jar:\

$TGH/lib/soap.jar:\

$TGH/bundled/j2ee/lib/j2ee.jar:\

$TGH/lib/guiBuilderBeanInfo.jar:\

$JDK_RT_JAR

../together $*

= END =================================

Together has started and ran fast BUT... there is no output in main panel (no classes in designer view, no code in coding view and so on) and no submenu in Project->Documentation->...

Resume:

So... JET does rocks, but it has bugs in it. And jet it too hard to use. It has too shy automatisation tools for large projects (like together) and makes you to think hardly about thinks needed to be done to compile it. Hope it's temporary problem.

PS: Thanx to kevin for help :).

Share this post


Link to post
Share on other sites
Sign in to follow this  

×