Jump to content
Excelsior Forums
etoy

SOS! Failed compile JRE!

Recommended Posts

Hi, everybody!

I download the evaluatation version 3.6 and installed it. But it seems that the JET can not complie my JRE.

The configuration of my system is below:

CPU: P4 1.8Mhz

RAM: 512 DDR

OS: Windows 2000 Professional with SP4

JRE version: 1.4.2_04 (build 1.4.2_04-b05)

Any help will be very appreciated!

Thanks in advance!

Share this post


Link to post
Share on other sites

Hi,

from time to time, we receive similar bug reports. The problem however is that we cannot reproduce it in our computer zoo which ranges from PII-200MHz-128MB to dual Xeon-2GHz-2GB with all possible Windows flavors (95, 98, ME, NT, 2000, XP including localized versions).

Once we observed such behavior on a box but it seemed to have a bad RAM stick. We cannot definitely assert that the only problem is hardware but so far we were unable to reproduce an installer crash on our end.

The problem is specific to installation only and never arises during ordinary compilation.

Could you, please, answer the following questions:

1) Does the problem appear on other machines?

2) Does the machine where you tried to install JET have anti-virus monitors installed? Some of JET users experienced similar problem due to interference of the monitors in installation process. They had startup items like OneTouch Scanner SW, Norton Anti-Virus, AVG, etc.

Probably, the monitors suspect JET Setup because it performs (read-only) access to existing files from the local system, namely rt.jar and creates DLLs.

3) Please, check the bios setup on this machine and try to choose the safest config ("Optimal settings" or something like that).  We received reports about crash in the JET installer caused by non-stable RAM if bios caching or shadowing was enabled. Selecting the safest config removed that problem.

Regards,

Excelsior Team

Share this post


Link to post
Share on other sites

Hi,

 Thanks for your advise, I compiled the JRE successfully on other machine. But the error occurs when I run the .exe file produced by JET, the detail of the error is below:

org.firebirdsql.ngds.InternalError: Failed to javaEnvironment->GetByteArrayElements

Caused by: org.firebirdsql.ngds.InternalError: Failed to javaEnvironment->GetByteArrayElements

My program query the FireBird database by FireBird JCA/JDBC driver 1.5.4, I used FireBird 1.5.2 in embedded mode.

The program runs properly with SUN JRE 1.4.2_04.

If you can help me ,I will very appreciated!

Regards,

etoy

Share this post


Link to post
Share on other sites

×