Jump to content
Excelsior Forums
andresito

Installing Modula2 under Linux

Recommended Posts

Please, i need to know all the steps to install XDS under linux, im using SUSE 10.0

I tried to follow the steps in the readme but i think i don't know how to do the first step.

I downloaded the latest XDS and the Topspeed pack. (please try to explain for begginers)

Thanks.

Share this post


Link to post
Share on other sites

I'll assume that english is not your birth language.  I am also assuming that this is more a language problem than a computer problem.  I will translate the instructions into simpler english.

1) If your system has a directory named /usr/local/xds,  the files will be installed there.

If your system does not have /usr/local/xds, the files will be installed in /usr/tmp.  Create /usr/local/xds, and move the files into it.

Change your path variable.  At a prompt, type: PATH=$PATH:/usr/local/xds/bin

1.2)  I did not do step 1.2, and my installation works fine.    I was using Fedora, not SUSE.  ( Does somebody else use SUSE ?  If so, please tell him what to do here. )

1.3)  At a prompt, type: su 

        At a prompt, type: cd /usr/local/xds

        At a prompt, type: ./apisyms-x86

2)    At a prompt, type: cd /usr/local/xds

        At a prompt, type: mkdir wrk

        At a prompt, type: cd wrk

        At a prompt, type: xcwork

If you still have errors, tell use exactly what error messages you get.  I think that I have seen most of them when I intalled mine.

Share this post


Link to post
Share on other sites

OK! that worked! and what about the TS extensions? I still have problems, I just moved the directory 'xds' from the 'xdsts' directory over the /usr/local/xds directory. When I do 'xc pepe.mod' the compiler tells me that it can't find the libray IO, and some *.sym files (but everything the program needs is in the same directory:  /usr/local/xds !!!!). 

I want to say that i've been using the TSM2 compiler and i needed to modify a .red redirection file to correct dependencies.

     

I'm from Argentina (South America), my root language is spanish, and if you still don't know where am I, im living in the same country where MARADONA lives (he was the best soccer player in the 80'). Thanks for your pacience.

Share this post


Link to post
Share on other sites

Could you please give us more information?

In particular, what is being imported into pepe.mod that cannot be found?

Share this post


Link to post
Share on other sites

Just out of curiousity, when you moved the ts directory over to /usr/local/xds - what did you do with the .sym files?  The redirection file has the compiler check /usr/local/xds/sym - so if you have them in a seperate directory outside of sym/ it won't be able to find them.

The compiler seems to find definition files fine, even if they are in subdirectories inside /usr/local/xds/def

It wouldn't do that with the symbol files. On mine, I have all of all the the ts symbol files just dumped in the x86 directory.  To keep my personal ones seperate, I had to physically edit /usr/local/xds/bin/xcwork

*.sym  = ./sym;$XDSDIR/sym/x86;$XDSDIR/sym/tkr

xc.red reads the same.  I can't remember if I manually changed that, or the system did, but I would say do it manually.  Remember though, that I am talking about adding a new directory to the symbol file directory.  The compiler should find the ts .sym files fine if they are inside of /usr/local/sym/x86

Terry

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×