Jump to content
Excelsior Forums
geek@work

Compilation fails

Recommended Posts

I'm using JET 3.5 Standard Edition build 0465 with jet-350-mp3.

After moving to Eclipse 3.1.2 from Eclipse 3.01 I'm getting the same type of error as this old posting http://www.excelsior-usa.com/forum/index.php?topic=350.0 below.

I am using the JET Evaluation version and attempting to compile an SWT GUI.  During compilation I get the following error:

#Compilation of class org/eclipse/jface/text/AbstractDocument failed:

#ASSERT(FALSE,15) at line 1451 of ControlFlow.ob2

I am using the swt and jface (jface.jar, jfacetext.jar) jars from eclipse 2.1.2.

I don't no what this error messge (from the full log) means so I don't know what to do about it.  Can someone help me out here?

Thanks,

James

If I compile in 3.01 it works fine, but if I recompile in 3.1.2 it fails.

TIA

Share this post


Link to post
Share on other sites

The problem should not appear in Excelsior JET since the version 3.6

Unfortunately, it cannot be fixed in older versions such as v3.5 because the respective part of the compiler was completely redesigned to fix this and other bugs that appeared when parsing class files.

I would recommend you to try the latest Excelsior JET 4.1?

? http://www.excelsior-usa.com/jetdleval.html

because we have substantially improved compatibility and stability of our product since the version 3.5 released 2 years ago.

--ZZ Top

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×