Jump to content
Excelsior Forums
Sign in to follow this  
basila

"Aborted" output under Linux when compiled with Evaluation v4.5.

Recommended Posts

I am using Excelsior JET 4.5 Eval (no updates installed) with JRE 1.5.0_06 on a Pentium 4 Mobile system with 768 MB of RAM running Linux and have the following question/problem:

I have a java application that I wrote which is simply a socket server that accepts connections on port 1978 and accepts simple requests.

The server is working fine on Windows and Linux when run as a normal java program. It also works great when compiled using Excelsior Evaluation v4.5 under windows.

However, there is a problem when running the executable that was produced using "Excelsior Evaluation v4.5 For Linux" under Linux Fedora Core 4 (Kernel 2.6.11-1.1369_FC4). The output of the program is simply "Aborted", and exits immediately. The excelsior compilation log had no complains at all when comiling, in addition, the "Test Run" step using the java normal code worked perfectly.

I have tried using different variations of the Excelsior settings (ie. inline expansion, JIT operation mode, Runtime, stack trace, etc) and repeating the compilation several times, with the same results (ie. "Aborted").

I have tried to print the shared library dependencies and got the following (if of any use):

[root@localhost bin]# ldd myprogram

linux-gate.so.1 =>  (0x001fb000)

libpthread.so.0 => /lib/libpthread.so.0 (0x00b16000)

libc.so.6 => /lib/libc.so.6 (0x008d3000)

libdl.so.2 => /lib/libdl.so.2 (0x00a25000)

/lib/ld-linux.so.2 (0x008b1000)

Linux distro : Fedora 4

Kernel revision : 2.6.11-1.1369_FC4

libc version : 2.3.5

Please help, Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×