Jump to content
Excelsior Forums
curdreinert

Windows Vista

Recommended Posts

Hi!

I couldn't find any hint on the JET web page, so I thought I might ask here. Do you have any experience in using JET on Windows Vista? Any problems, inconsistencies, caveat?  Maybe problems with older versions of JET?

Are you going to release any official statement about the compability of Vista and JET soon?

Many thanks,

    Curd Reinert

Share this post


Link to post
Share on other sites

Hello,

I understand the previous question was whether JET compiler will run under Vista.

My question, actually the question of my customers, is: do programs compiled with JET (4.5 or 4.8? ) 'normally' run on Vista? They will be getting their first machines with Vista beg. of next year and are anxious to know...

thanks

david

Share this post


Link to post
Share on other sites

Hello,

We tried to run programs compiled with JET 4.8 under Vista.

Some of them work perfectly, some do not. In fact, you should expect identical functionality of a JET-compiled program and the program running with the appropriate Sun JVM.

Share this post


Link to post
Share on other sites

As Vista is now available to the public and PCs are being sold with it on, those of us with products in the market need to be able to deliver Vista-compatible products.

Can we ask for the latest status on Vista-compatible versions of Jet, please?  We have actions in our software that work in the Java version on Vista and work when compiled with Jet and run on WinXP.  However, the Jet-compiled versions do not work properly when run under Vista (Business).

Differences observed so far are invisible checkboxes and drag and drop favicon to our product's window.

Share this post


Link to post
Share on other sites

Did you try to run your application with Sun JRE 5.0 on Vista? If yes, do not you see the same differences with it and what Sun JRE microversion did you use on Vista?

Share this post


Link to post
Share on other sites

Can we ask for the latest status on Vista-compatible versions of Jet, please?

In short, it's almost ready. After final testing and packaging, it will be generally available to the users of Excelsior JET 4.8 on the next week.

We also plan to add support for Vista to previous versions too such as Excelsior JET 4.5 though particular dates are not yet defined.

Share this post


Link to post
Share on other sites

> We also plan to add support for Vista to previous versions too such as Excelsior JET 4.5 though particular dates are not yet defined.

Excellent! As a 4.5 customer, I needed that gesture to keep me interested in upgrading any further...

Thanks!

JR

Share this post


Link to post
Share on other sites

> We also plan to add support for Vista to previous versions too such as Excelsior JET 4.5 though particular dates are not yet defined.

Any news on an update for 4.5?

Thank you,

JR

Share this post


Link to post
Share on other sites

Due to low demand for support Vista in JET 4.5, the dates are still undefined.  B)

The latest version 6.0 of Excelsior JET  has passed Java 6 JCK on Vista and has been officially certified Java compatible for that Windows flavor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×