Excelsior Logo Home
Buy   
Download   
Support   
 Forum   
Blog   

Excelsior JET 4.5 Maintenance Pack 2 Download

NOTE: This Maintenance Pack has been superceded by Maintenance Pack 4, which is now the recommended download.

Excelsior JET 4.5 Maintenance Pack 2 (MP2) is an optional update that fixes multiple customer issues. It supersedes Maintenance Pack 1 and incorporates all hotfixes you may have received from Excelsior Technical Support prior to August 3, 2006.

WARNING: Maintenance Packs fix particular problems reported by Excelsior JET users and discovered by Excelsior test engineers after the release of the respective version of the product. They are tested on a representative subset of the test suite used during preparation of the original release. We therefore only recommend you to install Maintenance Packs in the following cases:

  • You have been advised to do so by an Excelsior support engineer;
  • You need to switch to a Java SE (micro)version supported through a Maintenance Pack;
  • You want to try a new technology from Excelsior that requires installation of a particular Maintenance Pack; or
  • You are experiencing a severe problem, such as compiler or application crash or incorrect application behavior.

Release Notes

The most important issues resolved in Excelsior JET 4.5 Maintenance Pack 2 are as follows:

    JET-2440: AOT-compiler bug: ASSERT(FALSE,15) at line 427 of rfDFG.ob2

    JET-2449: JIT compiler bug: ASSERT(FALSE,15) at line 387 of formMem.ob2

Download Instructions

If you are a registered customer of Excelsior JET 4.5, but have not received a user/password combination for MP2 download, request it from our Support Dept. at support@excelsior-usa.com.

Depending on the platform and Excelsior JET Edition you are using, click one of the download links below:

Platform Edition Download
Windows Enterprise jet-450-mp2-ent-en-win32.exe Password Required
Professional jet-450-mp2-pro-en-win32.exe Password Required
Standard jet-450-mp2-std-en-win32.exe Password Required
Linux Enterprise jet-450-mp2-ent-en-linux.bin Password Required
Professional jet-450-mp2-pro-en-linux.bin Password Required
Standard jet-450-mp2-std-en-linux.bin Password Required

Installation Instructions

MP2 installs on top of the original Excelsior JET 4.5, possibly with previous hotfixes applied. If you need to make a fresh installation, install Excelsior JET 4.5 first, cancel JET Setup, and apply MP2.

To update an existing Excelsior JET installation, launch the downloaded executable and follow the on-line prompts. Upon successful copying of Maintenance Pack files, JET Setup will launch automatically and apply the Maintenance Pack.

Profile Management

Installation of MP2 does not obsolete your current profiles.

Update Management

Windows

To rollback to the previous update level, select Manage JET Updates in Excelsior JET Start Menu and click Undo.

Rollback does not remove the installed updates and associated profiles, so you can reapply MP2 later without installing it. Select Manage JET Updates and click Redo until it displays the current configuration as "jet-450-mp2".

Linux

  1. Run JET Setup to display the list of installed updates:
      jetsetup -show-updates
  2. Locate in the list the updates which you need to activate. Then run JET Setup again as follows:
      jetsetup -activate-update list

    where list is a colon-separated list of update names.

  3. Display the list of profiles available for the new combination of updates: jetsetup -show-profiles
  4. If necessary, create new profiles.

Home | Company | Products | Services | Resources | Contact

Store | Downloads | Support | Forum | Blog | Sitemap

© 1999-2015 Excelsior LLC. All Rights Reserved.